22 Nov 2009

Remote oil filter is plumbed but needs mounting. This position works well: it’s out of the way, easy to get to, the hoses are short, it’s helps balance weight, and spilled oil misses the tire. Plus, if and when an oil cooler is added, it’ll go in the right-side air-inlet, so the plumbing’s already mostly done. The filter housing is also a convenient source to drill and tap for turbo oil, oil temperature, and oil pressure sensors.

The big mess here is due to being in the middle of wiring and not taking time to clean up… hard to stop when I’m getting close. It’s a good thing the harness was unwrapped; what I labeled a ground wire was a major +12V supply line. It wouldn’t have burned anything up, but it sure wouldn’t have started. Found that the fuel pump expects a 20 amp fuse… yikes! Fortunately that possibility was designed-in ahead of time… though I expected pump current to be less.

With the wiring needed for first-start is done, it’ll be brought up slowly to avoid surprises. There’s also some more fuel fittings and hose to pick up, wiring in the larger-capacity injectors – I think the electrical connectors are different. First-start will just use a plastic lawnmower gas container; no point using the real tank and smelling fumes for months. Intake manifold has to be bolted in, fuel rail, too, as does the exhaust. The turbine housing is out for coating, which is just as well; it means the turbo oil supply isn’t needed just yet.

In case anyone thinks I did the entire electrical in just a couple days – only the wiring for starting the engine is in, which doesn’t require anything from the dash (even skipping the starter key for now.) That’s a whole ‘nother kettle of fish which will be handled later, maybe next, maybe not. In addition to wiring the entire dash is running all the wires for the lights – that’s actually the easiest part of the job.

Engine-start will be sooner than later (at least, trying to start it…), maybe within a week, and yes, the camcorder will be running.